docs.roxen.comView this page in a printer friendly mode
DocsRoxenWebServer 3.3Web Developer ManualCompatibility
Copyright  2004, Roxen Internet Software
Suggestions, comments & compliments
manuals@roxen.com
 DEMO  DOCS  PIKE
 COMMUNITY  DOWNLOAD
www.roxen.com



<counter>
<cset>
<if eval>

Compatibility

This chapter is only applicable when upgrading from an older version of a Roxen product. The use of tags listed here is not recommended.

Upgrading from 1.3 or older

With the redesign of RXML many tags have been rewritten to better fit into the new RXML design, some have been obsolete because of redundency matters, to avoid security and similar problems or simply because better tags have been invented.

The RXML syntax in Roxen Challenger 1.3 and Roxen WebServer 2.2 isn't compatible. This means that old websites built with Roxen Challenger won't operate properly under Roxen WebServer 2.1. To ensure full functionality in Roxen WebServer 2.1 one of these items has to be fulfilled.

  • Make the RXML code compatible with XML by adding /'s (slash) to all the tags, enclose all tag attributes with "'s (quotationmark) and remove tags like <formoutput> and <sqloutput>. Read more about XML here.

  • Add the appropriate 'Compatibility modules' to the site. The old RXML code on the site will now function exactly as it did in Roxen Challenger 1.3. Ask an administrator to enable the appropriate modules.